Changeset 17852 in niluje


Ignore:
Timestamp:
Oct 11, 2020, 2:43:27 AM (13 days ago)
Author:
NiLuJe
Message:

Kindle Hacks:

  • X-TC:
    • Fix requests deps again
File:
1 edited

Legend:

Unmodified
Added
Removed
  • Configs/trunk/Kindle/Misc/requests-git-deps.patch

    r17506 r17852  
    11diff --git a/requests/__init__.py b/requests/__init__.py
    2 index db090aa7..269c5eb8 100644
     2index db090aa7..2f2ade95 100644
    33--- a/requests/__init__.py
    44+++ b/requests/__init__.py
     
    2020-    assert minor >= 21
    2121-    assert minor <= 25
    22 +    if urllib3_version != ['dev']:
     22+    if 'dev' not in urllib3_version and 'dev0' not in urllib3_version:
    2323+        major, minor, patch = urllib3_version  # noqa: F811
    2424+        major, minor, patch = int(major), int(minor), int(patch)
    25 +        # urllib3 >= 1.21.1, <= 1.25
     25+        # urllib3 >= 1.21.1, <= 1.26
    2626+        assert major == 1
    2727+        assert minor >= 21
    28 +        assert minor <= 25
     28+        assert minor <= 26
    2929 
    3030     # Check chardet for compatibility.
     
    4141 
    4242 def _check_cryptography(cryptography_version):
     43diff --git a/setup.py b/setup.py
     44index a1b5a2a4..ece7521b 100755
     45--- a/setup.py
     46+++ b/setup.py
     47@@ -44,7 +44,7 @@ packages = ['requests']
     48 requires = [
     49     'chardet>=3.0.2,<4',
     50     'idna>=2.5,<3',
     51-    'urllib3>=1.21.1,<1.26,!=1.25.0,!=1.25.1',
     52+    'urllib3>=1.21.1,<1.27,!=1.25.0,!=1.25.1',
     53     'certifi>=2017.4.17'
     54 
     55 ]
Note: See TracChangeset for help on using the changeset viewer.